Orime

Ruby on RailsでLESSを使おう

March 29, 2014

【注意】


$ rails new hogehoge

で自動作成したプロジェクトのGemfileでは, デフォルトでSassが使えるように指定されてますよね.

# Use SCSS for stylesheets
gem 'sass-rails', '~> 4.0.2'

しかし僕はLESSを使いたいので, 書き換え.
less-rails を使います, リンク先のReadmeを参考にしましょう.

Gemfileを以下のように書き換え,

# - gem 'sass-rails', '~> 4.0.2'
gem 'less-rails'
gem 'therubyracer' # これも追加しないとエラー出る, はず

bundle installすれば,

....
Using less (2.5.0)
Using less-rails (2.5.0)
....

うん, これで完了かな?

development

Updated: December 12, 2018